mkinitcpio-dropbear/PKGBUILD
2024-05-09 12:51:13 +03:00

36 lines
1.3 KiB
Bash

# Maintainer: Marko Korhonen <marko@korhonen.cc>
# Contributor: Caleb Maclennan <caleb@alerque.com>
# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
pkgname=mkinitcpio-dropbear2
pkgname_="mkinitcpio-dropbear"
conflicts=("$pkgname_")
pkgver=0.1.0
pkgrel=1
pkgdesc='hook to install and enable the dropbear daemon in early userspace'
arch=(any)
url="https://git.korhonen.cc/FunctionalHacker/$pkgname_"
license=(GPL3)
depends=(dropbear psmisc)
optdepends=(
'mkinitcpio-netconf: Network interface configuration'
'mkinitcpio-ppp: PPP interface configuration'
'openssh: Allows the use of the same host keys used for normal access'
)
source=(
"dropbear_hook"
"dropbear_install"
"LICENSE"
)
backup=("etc/dropbear/config")
changelog=ChangeLog
sha256sums=('9852ab6a3ba4191ed3eabbfebb2876fe7ff1003f62309043ec0b8b9374e3b9ee'
'3f6cb2c6edd2a5510e9d2366b68815b0d0f9d7cfc066c26c4b842af44d2024fd'
'ac69d63ecc672c698582b0fc260dbfe42d71adcdab707f807c8e1113be11abd8')
package() {
install -Dm0644 dropbear_hook "$pkgdir/usr/lib/initcpio/hooks/dropbear"
install -Dm0644 dropbear_install "$pkgdir/usr/lib/initcpio/install/dropbear"
install -Dm0644 dropbear_config "$pkgdir/etc/dropbear/config"
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname_/" LICENSE
}